Click or drag to resize

SimpleArrayByte Class

Wrapper for ON_SimpleArray<unsigned char>. If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayByte

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayByte : IDisposable

The SimpleArrayByte type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayByte
Initializes a new SimpleArrayByte class.
Public methodSimpleArrayByte(IEnumerableByte)
Initializes a new SimpleArrayByte class
Public methodSimpleArrayByte(Int32)
Initializes a new SimpleArrayByte class. Initial size of the array - all values are set to zero.
Public methodSimpleArrayByte(SimpleArrayByte)
Initializes a new SimpleArrayByte with the contents of another SimpleArrayByte.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of elements in this array.
Top
Methods
  NameDescription
Public methodArray
Return the raw data.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodCopyTo
Copies the contents of a SimpleArrayByte into another SimpleArrayByte.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToArray
Returns the managed counterpart of the unmanaged array.
Top
See Also