Click or drag to resize

PostEffectData Class

This is a wrapper around the data ('on', 'shown', 'state' parameters, etc.) of a post effect.
Inheritance Hierarchy
SystemObject
  Rhino.Render.PostEffectsPostEffectData

Namespace:  Rhino.Render.PostEffects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public class PostEffectData : IDisposable

The PostEffectData type exposes the following members.

Properties
  NameDescription
Public propertyCollection
Public propertyId
Returns the unique id of this post effect.
Public propertyLocalName
Returns the localized name of this post effect.
Public propertyOn
The 'on' state of this post effect.
Public propertyShown
The 'shown' state of this post effect.
Public propertyType
Returns the type of this post effect.
Top
Methods
  NameDescription
Public methodDataCRC
Get a CRC representing the state of the entire post effect.
Public methodDispose
Releases all resources used by the PostEffectData
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the PostEffectData and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetParameter
Get an arbitrary parameter from this post effect by its name. If the parameter is not known to the post effect, the method will fail. Returns a variant object if successful or null on failure.
Public methodSetParameter
Set an arbitrary parameter to the post effect by its name. If the parameter is not known to the post effect, the method will fail. Returns true if successful or false on failure.
Top
See Also