Click or drag to resize

ContentFactory Class

[Missing <summary> documentation for "T:Rhino.Render.DataSources.ContentFactory"]

Inheritance Hierarchy
SystemObject
  Rhino.Render.DataSourcesContentFactory

Namespace:  Rhino.Render.DataSources
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ContentFactory : IDisposable

The ContentFactory type exposes the following members.

Constructors
  NameDescription
Public methodContentFactory
Initializes a new instance of the ContentFactory class
Top
Properties
  NameDescription
Public propertyCppPointer
Top
Methods
  NameDescription
Public methodContentTypeId
Public methodDispose
Releases all resources used by the ContentFactory
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodKind
Public methodNewContent
New Content returns a new content, which is Initialized with the Initialize() function. The content should be unitilized after use with the Unitialize function.
Top
See Also