Click or drag to resize

Mesh Class

Representation of ChangeQueue Mesh
Inheritance Hierarchy
SystemObject
  Rhino.Render.ChangeQueueMesh

Namespace:  Rhino.Render.ChangeQueue
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Mesh

The Mesh type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Get object attributes of object associated to this mesh. This will be possible only after returning true from ChangeQueue.ProvideOriginalObject()
Public propertyMapping
Get the mapping for this mesh.
Public propertyMappings
Get the mapping channels for this mesh
Public propertyObject
Get a copy of the original RhinoObject this Mesh is created from. Possible only after return true from ChangeQueue.ProvideOriginalObject(). Access this only with a using(var o = mesh.Object) {} construct. Note that the object is free floating, i.e. not part of a document.
Public propertyOcsTransform
OCS Transform for the MeshInstance - this is the Object Coordinate System texture mapping transformation set in the texture mapping properties dialog. (identity means no OCS, potentially just simple WCS/WCS Box)
Public propertySingleMapping Obsolete.
Get texture mapping info as single mapping
Public propertySingleMesh
Get the single mesh.
Top
Methods
  NameDescription
Public methodGetMeshes
Get a SimpleArrayMeshPointer containing all meshes for the related Mesh Since Rhino 8.0, this function only ever returns a single mesh. Use the Mesh property to get this single mesh.
Public methodId
Get the Object Guid this mesh is for.
Top
See Also