Click or drag to resize

Light Class

ChangeQueue Light change representation
Inheritance Hierarchy
SystemObject
  Rhino.Render.ChangeQueueLight

Namespace:  Rhino.Render.ChangeQueue
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Light

The Light type exposes the following members.

Properties
  NameDescription
Public propertyChangeType
Get what type of light change this represents
Public propertyData
Get the actual light data
Public propertyId
Get the light object id
Public propertyIdCrc
Get CRC computed from Id
Public propertyMaterialId
Get material ID of the material assigned to the light. Material ID is 0 if no material was assigned.
Top
Methods
  NameDescription
Top
See Also