Click or drag to resize

MeshClash Class

Represents a particular instance of a clash or intersection between two meshes.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.IntersectMeshClash

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshClash

The MeshClash type exposes the following members.

Properties
  NameDescription
Public propertyClashPoint
If valid, then the sphere centered at ClashPoint of ClashRadius distance intersects the clashing meshes.
Public propertyClashRadius
Gets the clash, or intersection, radius.
Public propertyMeshA
Gets the first mesh.
Public propertyMeshB
Gets the second mesh.
Top
Methods
  NameDescription
Public methodStatic memberFindDetail(RhinoObject, RhinoObject, Double)
Finds all of the mesh faces on each of two Rhino objects that interfere within a clash distance. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Public methodStatic memberFindDetail(RhinoObject, RhinoObject, Double, MeshType, MeshingParameters)
Finds all of the mesh faces on each of two Rhino objects that interfere within a clash distance. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Public methodStatic memberSearch(IEnumerableRhinoObject, IEnumerableRhinoObject, Double)
Searches for locations where the distance from a RhinoObject, in one set of objects, is less than the specified distance to another RhinoObject in a second set of objects. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Public methodStatic memberSearch(IEnumerableMesh, IEnumerableMesh, Double, Int32)
Searches for locations where the distance from a mesh in one set of meshes is less than distance to another mesh in a second set of meshes.
Public methodStatic memberSearch(Mesh, Mesh, Double, Int32)
Searches the locations where the distance from the first mesh to the second mesh is less than the provided value.
Public methodStatic memberSearch(Mesh, IEnumerableMesh, Double, Int32)
Searches the locations where the distance from the first mesh to a mesh in the second set of meshes is less than the provided value.
Public methodStatic memberSearch(IEnumerableRhinoObject, IEnumerableRhinoObject, Double, MeshType, MeshingParameters)
Searches for locations where the distance from a RhinoObject, in one set of objects, is less than the specified distance to another RhinoObject in a second set of objects. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Top
See Also