Click or drag to resize

MeshClashSearch Method (Mesh, Mesh, Double, Int32)

Searches the locations where the distance from the first mesh to the second mesh is less than the provided value.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static MeshClash[] Search(
	Mesh meshA,
	Mesh meshB,
	double distance,
	int maxEventCount
)

Parameters

meshA
Type: Rhino.GeometryMesh
The first mesh.
meshB
Type: Rhino.GeometryMesh
The second mesh.
distance
Type: SystemDouble
The largest distance at which there is a clash. All values smaller than this cause a clash as well.
maxEventCount
Type: SystemInt32
The maximum number of clash objects.

Return Value

Type: MeshClash
An array of clash objects.
See Also