DocumentSaveEventArgs Class |
Namespace: Rhino
The DocumentSaveEventArgs type exposes the following members.
Name | Description | |
---|---|---|
![]() | Document |
Gets the document for this event. This field might be null.
(Inherited from DocumentEventArgs.) |
![]() | DocumentId | Obsolete.
Gets the document Id of the document for this event.
(Inherited from DocumentEventArgs.) |
![]() | DocumentSerialNumber |
Gets the uniques document serial number for this event
(Inherited from DocumentEventArgs.) |
![]() | ExportSelected |
true if only selected objects are being written to a file.
|
![]() | FileName |
Name of file being written.
|
Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |