Click or drag to resize

PythonScript Properties

The PythonScript type exposes the following members.

Properties
  NameDescription
Public propertyContextId
Gets or sets a context unique identified.
Public propertyOutput
Gets or sets the Python script "print()" target.

By default string output goes to the Rhino.RhinoApp.Write function. Set Output if you want to redirect the output from python to a different function while this script executes.

Public propertyScriptContextCommand
Command associated with this script. Used for localiation
Public propertyScriptContextDoc
object set to variable held in scriptcontext.doc.
Public propertyStatic memberSearchPaths
Get/Set additional search paths used by the python interpreter
Top
See Also