Click or drag to resize

VolumeMassProperties Properties

The VolumeMassProperties type exposes the following members.

Properties
  NameDescription
Public propertyCentroid
Gets the volume centroid in the world coordinate system.
Public propertyCentroidCoordinatesMomentsOfInertia
Moments of inertia with respect to centroid coordinate system. X = integral of ((y-y0)^2 + (z-z0)^2) dm Y = integral of ((z-z0)^2 + (x-x0)^2) dm Z = integral of ((z-z0)^2 + (y-y0)^2) dm where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesMomentsOfInertiaError
Uncertainty in centroid coordinates moments of inertia calculation.
Public propertyCentroidCoordinatesProductMoments
Product moments with respect to centroid coordinate system.
Public propertyCentroidCoordinatesProductMomentsError
Uncertainty in product moments with respect to centroid coordinate system.
Public propertyCentroidCoordinatesRadiiOfGyration
Radii of gyration with respect to centroid coordinate system. X = sqrt(integral of ((y-y0)^2 + (z-z0)^2) dm/M) Y = sqrt(integral of ((z-z0)^2 + (x-x0)^2) dm/M) Z = sqrt(integral of ((z-z0)^2 + (y-y0)^2) dm/M) where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesSecondMoments
Second moments with respect to centroid coordinate system. X = integral of (x-x0)^2 dm Y = integral of (y-y0)^2 dm Z = integral of (z-z0)^2 dm where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesSecondMomentsError
Uncertainty in centroid coordinates second moments calculation.
Public propertyCentroidError
Gets the uncertainty in the Centroid calculation.
Public propertyCode exampleVolume
Gets the volume solution.
Public propertyCode exampleVolumeError
Gets the uncertainty in the volume calculation.
Public propertyWorldCoordinatesFirstMoments
Returns the world coordinate first moments if they were able to be calculated. X is integral of "x dm" over the volume Y is integral of "y dm" over the volume Z is integral of "z dm" over the volume.
Public propertyWorldCoordinatesFirstMomentsError
Uncertainty in world coordinates first moments calculation.
Public propertyWorldCoordinatesMomentsOfInertia
The moments of inertia about the world coordinate axes. X = integral of (y^2 + z^2) dm Y = integral of (z^2 + x^2) dm Z = integral of (z^2 + y^2) dm.
Public propertyWorldCoordinatesMomentsOfInertiaError
Uncertainty in world coordinates moments of inertia calculation.
Public propertyWorldCoordinatesProductMoments
Returns the world coordinate product moments if they were able to be calculated. X is integral of "xy dm" over the volume Y is integral of "yz dm" over the volume Z is integral of "zx dm" over the volume.
Public propertyWorldCoordinatesProductMomentsError
Uncertainty in world coordinates second moments calculation.
Public propertyWorldCoordinatesRadiiOfGyration
Radii of gyration with respect to world coordinate system. X = sqrt(integral of (y^2 + z^2) dm/M) Y = sqrt(integral of (z^2 + x^2) dm/M) Z = sqrt(integral of (z^2 + y^2) dm/M)
Public propertyWorldCoordinatesSecondMoments
Returns the world coordinate second moments if they were able to be calculated. X is integral of "xx dm" over the volume Y is integral of "yy dm" over the volume Z is integral of "zz dm" over the volume.
Public propertyWorldCoordinatesSecondMomentsError
Uncertainty in world coordinates second moments calculation.
Top
See Also