Click or drag to resize

SubDCreationOptions Properties

The SubDCreationOptions type exposes the following members.

Properties
  NameDescription
Public propertyConcaveCornerTest
Get or sets the concave corner test option.
Public propertyStatic memberConvexAndConcaveCornersAndInteriorCreases
Look for convex corners at sub-D vertices with 2 edges or fewer that have an included angle ≤ 120 degrees. Look for concave corners at sub-D vertices with 3 edges or more that have an included angle ≥ 240 degrees.
Public propertyStatic memberConvexCornersAndInteriorCreases
Look for convex corners at sub-D vertices with 2 edges or fewer that have an included angle ≤ 120 degrees.
Public propertyConvexCornerTest
Get or sets the convex corner test option.
Public propertyStatic memberInteriorCreases
Create an interior sub-D crease along all input mesh double edges
Public propertyInteriorCreaseTest
Get or sets the interior crease test option.
Public propertyInterpolateMeshVertices
If false, input mesh vertex locations will be used to set SubD vertex control net locations. If true, input mesh vertex locations will be used to set SubD vertex limit surface locations.
Public propertyMaximumConvexCornerAngleRadians
If ConvexCornerTest == ConvexCornerOption.AtMeshCorner, then an input mesh boundary vertex becomes a SubD corner when the number of edges that end at the vertex is <= MaximumConvexCornerEdgeCount edges and the corner angle is <= MaximumConvexCornerAngleRadians.
Public propertyMaximumConvexCornerEdgeCount
If ConvexCornerTest == ConvexCornerOption.AtMeshCorner, then an input mesh boundary vertex becomes a SubD corner when the number of edges that end at the vertex is <= MaximumConvexCornerEdgeCount edges and the corner angle is <= MaximumConvexCornerAngleRadians.
Public propertyMinimumConcaveCornerAngleRadians
If ConcaveCornerTest == ConcaveCornerOption.AtMeshCorner, then an input mesh boundary vertex becomes a SubD corner when the number of edges that end at the vertex is >= MinimumConcaveCornerEdgeCount edges and the corner angle is >= MinimumConcaveCornerAngleRadians.
Public propertyMinimumConcaveCornerEdgeCount
If ConcaveCornerTest == ConcaveCornerOption.AtMeshCorner, then an input mesh boundary vertex becomes a SubD corner when the number of edges that end at the vertex is >= MinimumConcaveCornerEdgeCount edges and the corner angle is >= MinimumConcaveCornerAngleRadians.
Public propertyStatic memberSmooth
No interior creases and no corners.
Top
See Also