Click or drag to resize

SquishParameters Properties

The SquishParameters type exposes the following members.

Properties
  NameDescription
Public propertyAbsoluteLimit
If -1.0 <= AnsoluteLimit < 0.0, then then an absolute compression limit is applied so that (2d length)/(3d length) >= abs(AbsoluteLimit). In particular, Absolute = -1.0, then no compression is permitted(2d length) >= (3d length). If 0.0 < m_absolute_limit <= 1.0 then then an absolute stretching limit is applied so that (2d length)/(3d length) <= 1/abs(AbsoluteLimit). Examples: AbsoluteLimit 1.0: no stretching, (2d length) <= 1.0*(3d length) 0.5: cap on stretching, 0.5*(2d length) <= (3d length) -0.5: cap on compression, (2d length) >= 0.5*(3d length) -1.0: no compression, (2d length) >= 1.0*(3d length)
Public propertyAlgorithm
The flattening algorithm to use: Geometric: (scale independent)the "spring" constant is proportional to 1/L^2 and the result is independent of scale. PhysicalStress: (scale dependent) the "spring" constant is proportional to 1/L.
Public propertyBoundaryCompressConstant
Spring constant for compressed boundary edges times the rest length
Public propertyBoundaryStretchConstant
Spring constant for stretched boundary edges
Public propertyStatic memberDefault
Gets the default Squishing parameters
Public propertyInteriorCompressConstant
Spring constant for compressed interior edges times the rest length
Public propertyInteriorStretchConstant
Spring constant for stretched boundary edges times the rest length
Public propertyPreserveTopology
the mesh has coincident vertices and PreserveTopology is true, then the flattening is based on the mesh's topology and coincident vertices will remain coincident. Otherwise coincident vertices are free to move apart.
Public propertySaveMapping
If SaveMapping is true, then ON_SquishMesh() will save extra information on the squished mesh so 3d points and curves near the input mesh can be mapped to the squished mesh and 2d points and curves on the squished mesh can be mapped back to the 3d mesh.
Top
See Also