Click or drag to resize

RTreeEventArgs Properties

The RTreeEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyCancel
Gets or sets a value that determines if the search should be conducted farther.
Public propertyId
Gets the identifier of the found item.
Public propertyIdB
If search is using two r-trees, IdB is element b in the search.
Public propertyIdBPtr
If search is using two r-trees, IdB is the element b pointer in the search.
Public propertyIdPtr
Gets the identifier pointer of the found item.
Public propertySearchBoundingBox
Bounding box bounds used during a search. You may modify the box in a search callback to help reduce the bounds to search.
Public propertySearchSphere
Sphere bounds used during a search. You can modify the sphere in a search callback to help reduce the bounds to search.
Public propertyTag
Gets or sets an arbitrary object that can be attached to this event args. This object will "stick" through a single search and can represent user-defined state.
Top
See Also