Click or drag to resize

PointCloudItem Properties

The PointCloudItem type exposes the following members.

Properties
  NameDescription
Public propertyColor
Gets or sets the color of this point cloud item. If this point cloud item does not have a color, System.Drawing.Color.Black is returned.
Public propertyHidden
Gets or sets the hidden flag of this point cloud item. If this point cloud item does not have a hidden flag, false is returned.
Public propertyIndex
Gets the index of this point cloud item.
Public propertyLocation
Gets or sets the location of this point cloud item.
Public propertyNormal
Gets or sets the normal vector for this point cloud item. If this point cloud item does not have a normal vector, Vector3d.Unset is returned.
Public propertyPointValue
Gets or set the extra value of this point cloud item. The extra value can be used to store a user-defined value, such as intensity. If this point cloud item does not have an extra value, RhinoMath.UnsetValue is returned.
Public propertyX
Gets or sets the X component of this point cloud item location.
Public propertyY
Gets or sets the Y component of this point cloud item location.
Public propertyZ
Gets or sets the Z component of this point cloud item location.
Top
See Also