Click or drag to resize

Plane Properties

The Plane type exposes the following members.

Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether or not this is a valid plane. A plane is considered to be valid when all fields contain reasonable information and the equation jibes with point and z-axis.
Public propertyNormal
Gets the normal of this plane. This is essentially the ZAxis of the plane.
Public propertyOrigin
Gets or sets the origin point of this plane.
Public propertyOriginX
Gets or sets the X coordinate of the origin of this plane.
Public propertyOriginY
Gets or sets the Y coordinate of the origin of this plane.
Public propertyOriginZ
Gets or sets the Z coordinate of the origin of this plane.
Public propertyStatic memberUnset
Gets a plane that contains Unset origin and axis vectors.
Public propertyStatic memberWorldXY
plane coincident with the World XY plane.
Public propertyStatic memberWorldYZ
plane coincident with the World YZ plane.
Public propertyStatic memberWorldZX
plane coincident with the World ZX plane.
Public propertyXAxis
Gets or sets the X axis vector of this plane.
Public propertyYAxis
Gets or sets the Y axis vector of this plane.
Public propertyZAxis
Gets or sets the Z axis vector of this plane.
Top
See Also