Click or drag to resize

MeshCheckParameters Properties

The MeshCheckParameters type exposes the following members.

Properties
  NameDescription
Public propertyCheckForBadNormals
If true, then look for vertex normals that are not unit vectors, are zero length or vary greatly from the general direction of the face normals.
Public propertyCheckForDegenerateFaces
If true, then look for triangles and quads that have zero area and quads where one sub triangle has zero area.
Public propertyCheckForDisjointMeshes
If true, then look for faces in the mesh that are totally isolated from other faces in the mesh. (i.e. an island of faces, or many islands, that have a boundary of naked edges)
Public propertyCheckForDuplicateFaces
If true, then look for faces that have vertices (not necessarily vertex indexes) that are identical.
Public propertyCheckForExtremelyShortEdges
If true, then look for topological edges where the distance between the endpoints is less than ExtremelyShortEdgeDistance.
Public propertyCheckForInvalidNgons
If true, then look for ngons that have invalid information.
Public propertyCheckForNakedEdges
If true, then look for topological edges in the mesh topology where the face count is 1. Note, this check is also made if CheckForDuplicateFaces is true but the output is not shown if CheckForNakedEdges is false.
Public propertyCheckForNonManifoldEdges
If true, then look for topological edges in the mesh topology where the face count is greater than 2. Note, this check is also made if CheckForDuplicateFaces is true but the output is not shown if CheckForNonManifoldEdges is false.
Public propertyCheckForRandomFaceNormals
If true, then look for adjacent faces that have the same edge orientation. This typically means that clockwise/counterclockwise orientation, and face normal are not in sync.
Public propertyCheckForSelfIntersection
If true, then look for self intersections.
Public propertyCheckForUnusedVertices
If true, then look for vertices that are not referenced by any face in the mesh.
Public propertyDegenerateFaceCount
Gets the total degenerate face count for all meshes.
Public propertyDisjointMeshCount
Gets the total count of disjoint pieces for all meshes.
Public propertyDuplicateFaceCount
Gets the total count of duplicate faces for all meshes.
Public propertyExtremelyShortEdgeCount
Gets the total number of extremely short edges for all meshes.
Public propertyInvalidNgonCount
Gets the total number of invalid ngons for all meshes.
Public propertyNakedEdgeCount
Gets the total number of naked edges for all meshes.
Public propertyNonManifoldEdgeCount
Gets the total number of non-manifold edges for all meshes.
Public propertyNonUnitVectorNormalCount
Get the total count of normals that are not unit vectors for all meshes.
Public propertyRandomFaceNormalCount
Gets the total count of random face normals for all meshes.
Public propertySelfIntersectingPairsCount
Gets the total count of self intersections for all meshes.
Public propertyUnusedVertexCount
Gets the total count of unused vertices for all meshes.
Public propertyVertexFaceNormalsDifferCount
Gets the total count of vertex normals that differ greatly from face normals for all meshes.
Public propertyZeroLengthNormalCount
Gets the total count of zero length normals for all meshes.
Top
See Also