Click or drag to resize

HiddenLineDrawingObjectCurve Properties

The HiddenLineDrawingObjectCurve type exposes the following members.

Properties
  NameDescription
Public propertyClippingPlaneIndex
Index into HiddenLineDrawing.ClippingPlanes when SilhouetteType == SilhouetteType.SectionCut.
Public propertyIndex
Index of this object in HiddenLineDrawing.FullCurves.
Public propertyIsProjecting
Returns true if all the non clipped portions of this curve are projecting.
Public propertyIsValid
Verifies the object is valid.
Public propertyOriginalDomainStart
Initialized to RhinoMath.UnsetValue. Valid if the full curve is closed. Rejoin can reparameterize the curve by moving the seam. When this has been done the original domain start is stored here.
Public propertyParameters
Increasing, partition of curve.Domain.
Public propertySegments
The HiddenLineDrawingCurve objects that make up this full curve.
Public propertySilhouetteType
The silhouette event type
Public propertySourceObject
Return the source object that this curve came from
Public propertySourceObjectComponentIndex
Component of source object part that generated this curve.
Top
See Also