Click or drag to resize

Circle Properties

The Circle type exposes the following members.

Properties
  NameDescription
Public propertyBoundingBox
Gets the circle's 3d axis aligned bounding box.
Public propertyCenter
Gets or sets the center point of this circle.
Public propertyCircumference
Gets or sets the circumference of this circle.
Public propertyDiameter
Gets or sets the diameter (radius * 2.0) of this circle. Diameters should be positive values.
Public propertyIsValid
A valid circle has radius larger than 0.0 and a base plane which is must also be valid.
Public propertyNormal
Gets the normal vector for this circle.
Public propertyPlane
Gets or sets the plane of the circle.
Public propertyRadius
Gets or sets the radius of this circle. Radii should be positive values.
Public propertyStatic memberUnset
Gets a circle with Unset components.
Top
See Also