Click or drag to resize

Texture Properties

The Texture type exposes the following members.

Properties
  NameDescription
Public propertyApplyUvwTransform
If true then the UVW transform is applied to the texture otherwise the UVW transform is ignored.
Public propertyEnabled
If the texture is enabled then it will be visible in the rendered display otherwise it will not.
Public propertyFileName
Gets or sets a file name that is used by this texture.

NOTE: We are moving away from string-based FileName, and suggest the usage of the new FileReference class.

Also, this filename may well not be a path that makes sense on a user's computer because it was a path initially set on a different user's computer. If you want to get a workable path for this user, use the BitmapTable.Find function using this property.

Public propertyFileReference
Gets or sets a copy of the file reference that is used by this texture.
Remarks
After the get or the set method complete, you own the copy you received or passed in, and can Dispose() of it.
Public propertyId
Gets the globally unique identifier of this texture.
Public propertyMagFilter
The MagFilter setting controls how the color of the image pixel is calculated when the image pixel corresponds to a fraction of a texture bitmap pixel.
Public propertyMappingChannelId
Public propertyMinFilter
The MinFilter setting controls how the color of the image pixel is calculated when the image pixel corresponds to multiple texture bitmap pixels.
Public propertyOffset
Helper for access to the offset value encoded in UvwTransform
Public propertyProjectionMode
How texture is projected onto geometry
Public propertyRepeat
Helper for access to the repeat value encoded in UvwTransform
Public propertyRotation
Helper for access to the rotation value encoded in UvwTransform
Public propertyTextureCombineMode
Determines how this texture is combined with others in a material's texture list.
Public propertyTextureType
Controls how the pixels in the bitmap are interpreted
Public propertyTreatAsLinear
If false, the texture color values should be correctly by the linear workflow pre-process gamma value (in the document) if linear workflow is on. Otherwise, if the values is true, the values should be used raw from the texture.
Public propertyUvwTransform
Transform to be applied to each instance of this texture if ApplyUvw is true
Public propertyWcsBoxProjected
Is true if this texture uses world coordinate system (WCS) box projection for texture mapping. Notice: If this texture is used by an object that has an object coordinate system (OCS) frame defined on a mapping channel then that OCS frame is used instead of the WCS.
Public propertyWcsProjected
Is true if this texture uses world coordinate system (WCS) projection for texture mapping. Notice: If this texture is used by an object that has an object coordinate system (OCS) frame defined on a mapping channel then that OCS frame is used instead of the WCS.
Public propertyWrapU
Texture wrapping mode in the U direction
Public propertyWrapV
Texture wrapping mode in the V direction
Public propertyWrapW
Texture wrapping mode in the W direction
Top
See Also