Click or drag to resize

UserData Properties

The UserData type exposes the following members.

Properties
  NameDescription
Public propertyDescription
Descriptive name of the user data.
Public propertyShouldWrite
If you want to save this user data in a 3dm file, override ShouldWrite and return true. If you do support serialization, you must also override the Read and Write functions.
Public propertyTransform
Updated if user data is attached to a piece of geometry that is transformed and the virtual OnTransform() is not overridden. If you override OnTransform() and want Transform to be updated, then call the base class OnTransform() in your override. The default constructor sets Transform to the identity.
Top
See Also