Click or drag to resize

Command Properties

The Command type exposes the following members.

Properties
  NameDescription
Protected propertyCommandContextHelpUrl
Gets the URL of the command contextual help. This is usually a location of a local CHM file.

The default implementation return an empty string.

Public propertyEnglishName
Gets the name of the command. This method is abstract.
Public propertyId
Gets the unique ID of this command. It is best to use a Guid attribute for each custom derived command class since this will keep the id consistent between sessions of Rhino GuidAttribute
Public propertyStatic memberLastCommandId
Gets the ID of the last commands.
Public propertyStatic memberLastCommandResult
Gets the result code of the last command.
Public propertyLocalName
Gets the local name of the command.
Public propertyPlugIn
Gets the plug-in where this commands is placed.
Public propertySettings
Gets the settings of the command.
Top
See Also