Click or drag to resize

Notification Methods

The Notification type exposes the following members.

Methods
  NameDescription
Public methodEditable
Determines whether an assembly can modify the instance. Any code that modifies an assembly protected notification must be wrapped in a ExecuteAssemblyProtectedCode(Action) method.
Public methodStatic memberExecuteAssemblyProtectedCode(Action)
If a Notification object is only allowed to be modified by certain assemblies, then any code that interacts with it must be wrapped around this method, or a InvalidOperationException will be thrown. For performance reasons, the code wrapped by this method should be kept as simple as possible.
Public methodStatic memberExecuteAssemblyProtectedCodeTResult(FuncTResult)
If a Notification object is only allowed to be modified by certain assemblies, then any code that interacts with it must be wrapped around this method, or a InvalidOperationException will be thrown. For performance reasons, the code wrapped by this method should be kept as simple as possible.
Public methodHideModal
Tells Rhino to hide the notification if it is being currently shown as a modal.
Public methodRemoveMetadata
Removes metadata from this instance.
Public methodShowModal
Tells Rhino to display the notification modally.
Public methodToString
Returns a readable string representation of the instance.
(Overrides ObjectToString.)
Top
See Also