Click or drag to resize

NamedPositionTable Methods

The NamedPositionTable type exposes the following members.

Methods
  NameDescription
Public methodAppend(Guid, IEnumerableRhinoObject)
Append objects to a Named Position.
Public methodAppend(Guid, IEnumerableGuid)
Append objects to a Named Position.
Public methodAppend(String, IEnumerableRhinoObject)
Append objects to a Named Position.
Public methodAppend(String, IEnumerableGuid)
Append objects to a Named Position.
Public methodDelete(Guid)
Delete a Named Position.
Public methodDelete(String)
Delete a Named Position.
Public methodId
Guid of a Named Position.
Public methodName
Name of a Named Position.
Public methodObjectIds(Guid)
Array of Rhino Object Guids related to a Named Position.
Public methodObjectIds(String)
Array of Rhino Object Guids related to a Named Position.
Public methodObjects(Guid)
Array of Rhino Objects related to a Named Position.
Public methodObjects(String)
Array of Rhino Objects related to a Named Position.
Public methodObjectXform(Guid, RhinoObject, Transform)
Retrieve the Transform of a Rhino Object relate to a Named Position.
Public methodObjectXform(Guid, Guid, Transform)
Retrieve the Transform of a Rhino Object relate to a Named Position.
Public methodRename(Guid, String)
Rename a Named Position.
Public methodRename(String, String)
Rename a Named Position.
Public methodRestore(Guid)
Restore a Named Position.
Public methodRestore(String)
Restore a Named Position.
Public methodSave(String, IEnumerableRhinoObject)
Save a new Named Position.
Public methodSave(String, IEnumerableGuid)
Save a new Named Position.
Public methodUpdate(Guid)
Updates a Named Position, effectively storing the current positions of the objects which the Named Position is tracking.
Public methodUpdate(String)
Updates a Named Position, effectively storing the current positions of the objects which the Named Position is tracking.
Top
See Also