Click or drag to resize

NamedPositionTableObjectXform Method (Guid, RhinoObject, Transform)

Retrieve the Transform of a Rhino Object relate to a Named Position.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool ObjectXform(
	Guid id,
	RhinoObject obj,
	ref Transform xform
)

Parameters

id
Type: SystemGuid
The Guid of the Named Position
obj
Type: Rhino.DocObjectsRhinoObject
The Rhino Object from which to retrieve the Transform.
xform
Type: Rhino.GeometryTransform
The Transform to retrieve.

Return Value

Type: Boolean
Transform of the RhinoObject related to the Named Position.
See Also