Click or drag to resize

CustomRenderMeshProvider2WillBuildCustomMeshes Method (ViewportInfo, RhinoObject, Guid, Boolean)

[Missing <summary> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.4
Syntax
public override bool WillBuildCustomMeshes(
	ViewportInfo vp,
	RhinoObject obj,
	Guid requestingPlugIn,
	bool preview
)

Parameters

vp
Type: Rhino.DocObjectsViewportInfo

[Missing <param name="vp"/> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

obj
Type: Rhino.DocObjectsRhinoObject

[Missing <param name="obj"/> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

requestingPlugIn
Type: SystemGuid

[Missing <param name="requestingPlugIn"/> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

preview
Type: SystemBoolean

[Missing <param name="preview"/> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Render.CustomRenderMeshProvider2.WillBuildCustomMeshes(Rhino.DocObjects.ViewportInfo,Rhino.DocObjects.RhinoObject,System.Guid,System.Boolean)"]

See Also