Click or drag to resize

IntersectionLineBox Method (Line, Box, Double, Interval)

Intersects an infinite line with a box volume.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static bool LineBox(
	Line line,
	Box box,
	double tolerance,
	out Interval lineParameters
)

Parameters

line
Type: Rhino.GeometryLine
Line for intersection.
box
Type: Rhino.GeometryBox
Box to intersect.
tolerance
Type: SystemDouble
If tolerance > 0.0, then the intersection is performed against a box that has each side moved out by tolerance.
lineParameters
Type: Rhino.GeometryInterval
The chord from line.PointAt(lineParameters.T0) to line.PointAt(lineParameters.T1) is the intersection.

Return Value

Type: Boolean
true if the line intersects the box, false if no intersection occurs.
See Also