InterpolatorInterpolateLinear Method |
Sample the list of numbers with linear interpolation.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public double InterpolateLinear(
double t
)
Public Function InterpolateLinear (
t As Double
) As Double
Parameters
- t
- Type: SystemDouble
Parameter to sample at. The integer portion of the parameter
indicates the index of the left-hand value. If this Interpolator is cyclical,
parameters will be wrapped.
Return Value
Type:
DoubleThe sampled value at t.
See Also