HiddenLineDrawingParametersAddGeometry Method (GeometryBase, Object) |
Add geometry that should be included in the calculation
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public bool AddGeometry(
GeometryBase geometry,
Object tag
)
Public Function AddGeometry (
geometry As GeometryBase,
tag As Object
) As Boolean
Parameters
- geometry
- Type: Rhino.GeometryGeometryBase
Currently only curves, meshes, breps, surfaces, and extrusions are supported
- tag
- Type: SystemObject
arbitrary data to be associated with this geometry
Return Value
Type:
Boolean
true if the type of geometry can be added for calculations.
Currently only curves, meshes, breps, surfaces and extrusions are supported
See Also