Click or drag to resize

File3dmMaterialTableAddMaterial Method

Adds a material to the model material table

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.4
Syntax
public int AddMaterial(
	Material material
)

Parameters

material
Type: Rhino.DocObjectsMaterial

[Missing <param name="material"/> documentation for "M:Rhino.FileIO.File3dmMaterialTable.AddMaterial(Rhino.DocObjects.Material)"]

Return Value

Type: Int32
The material's index (>=0) is returned. Otherwise, RhinoMath.UnsetIntIndex is returned.
See Also