Click or drag to resize

InstanceObjectUsesDefinition Method

Determine if this reference uses an instance definition

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.2
Syntax
public bool UsesDefinition(
	int definitionIndex,
	out int nestingLevel
)

Parameters

definitionIndex
Type: SystemInt32

[Missing <param name="definitionIndex"/> documentation for "M:Rhino.DocObjects.InstanceObject.UsesDefinition(System.Int32,System.Int32@)"]

nestingLevel
Type: SystemInt32
If the instance definition is used, this is the definition's nesting depth

Return Value

Type: Boolean
true or false depending on if the definition is used
See Also