Click or drag to resize

RhinoViewportGetDepth Method (Point3d, Double)

Gets clipping distance of a point.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool GetDepth(
	Point3d point,
	out double distance
)

Parameters

point
Type: Rhino.GeometryPoint3d
A 3D point.
distance
Type: SystemDouble
A computed distance is assigned to this out parameter if this call succeeds.

Return Value

Type: Boolean
true if the point is in the view frustum and near_dist/far_dist were set. false if the bounding box does not intersect the view frustum.
See Also