Click or drag to resize

ArchivableDictionaryGetPoint3d Method (String, Point3d)

Get value as Point3d, will return defaultValue unless value was created using Set(string key, Point3d value)

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point3d GetPoint3d(
	string key,
	Point3d defaultValue
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetPoint3d(System.String,Rhino.Geometry.Point3d)"]

defaultValue
Type: Rhino.GeometryPoint3d

[Missing <param name="defaultValue"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetPoint3d(System.String,Rhino.Geometry.Point3d)"]

Return Value

Type: Point3d

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.GetPoint3d(System.String,Rhino.Geometry.Point3d)"]

See Also