Click or drag to resize

RhinoDoc Events

The RhinoDoc type exposes the following members.

Events
  NameDescription
Public eventStatic memberActiveDocumentChanged
This event is raised when the active document used by modeless user interface changes. On Mac Rhino this will get raised before the NewDocument, BeginOpenDocument and EndOpenDocument events. Mac Rhino will also raise this event with 0 for the document Id and a null document pointer when the last document is closed. Windows Rhino will raise this event after the NewDocument, BeginOpenDocument and EndOpenDocument events when a new or existing model is opened.
Public eventStatic memberAddRhinoObject
Called if a new object is added to the document.
Public eventStatic memberCode exampleBeforeTransformObjects
Called before objects are being transformed
Public eventStatic memberBeginOpenDocument
This event is raised when the document open operation begins. NOTE: On Windows, this event will be fired when a clipboard paste operation occurs, as Rhino opens a .tmp file in the User's Local folder with the contents of the pasted document.
Public eventStatic memberBeginSaveDocument
Public eventStatic memberCloseDocument
Public eventStatic memberDeleteRhinoObject
Called if an object is deleted. At some later point the object can be un-deleted.
Public eventStatic memberDeselectAllObjects
Called when all objects are deselected.
Public eventStatic memberDeselectObjects
Called when object(s) are deselected.
Public eventStatic memberDimensionStyleTableEvent
Called when any modification happens to a document's dimension style table.
Public eventStatic memberDocumentPropertiesChanged
Public eventStatic memberEndOpenDocument
Public eventStatic memberEndOpenDocumentInitialViewUpdate
This event is raised after EndOpenDocument when the documents initial views have been created and initialized.
Public eventStatic memberEndSaveDocument
Public eventStatic memberGroupTableEvent
Called when any modification happens to a document's group table.
Public eventStatic memberInstanceDefinitionTableEvent
Called when any modification happens to a document's instance definition table.
Public eventStatic memberLayerTableEvent
Called when any modification happens to a document's layer table.
Public eventStatic memberLightTableEvent
Called when any modification happens to a document's light table.
Public eventStatic memberLinetypeTableEvent
Called when any modification happens to a document's linetype table.
Public eventStatic memberMaterialTableEvent
Called when any modification happens to a document's material table.
Public eventStatic memberModifyObjectAttributes
Called when all object attributes are changed.
Public eventStatic memberNewDocument
Public eventStatic memberPurgeRhinoObject
Called if an object is being purged from a document. The object will cease to exist forever.
Public eventStatic memberRenderEnvironmentTableEvent
Public eventStatic memberRenderMaterialsTableEvent
Public eventStatic memberRenderTextureTableEvent
Called when the RenderTextureTable has been loaded, is about to be cleared or has been cleared. See RhinoDocRenderContentTableEventType for more information.
Public eventStatic memberReplaceRhinoObject
Called if an object is about to be replaced. If both RhinoDoc.UndoActive() and RhinoDoc.RedoActive() return false, then immediately after the ReplaceObject event, there will be a DeleteObject event followed by an AddObject event. If either RhinoDoc.UndoActive() or RhinoDoc::RedoActive() return true, then immediately after the ReplaceObject event, there will be a DeleteObject event followed by an UndeleteObject event.
Public eventStatic memberSelectObjects
Called when object(s) are selected.
Public eventStatic memberTextureMappingEvent
Called when any modification happens to a document objects texture mapping.
Public eventStatic memberUndeleteRhinoObject
Called if an object is un-deleted.
Public eventStatic memberUnitsChangedWithScaling
Called when a change in the model units results in a scaling operation on all of the objects in the document. This call is made before any of the objects are scaled. A call to RhinoDoc.DocumentPropertiesChanged follows.
Public eventStatic memberUserStringChanged
This event is raised when document user text strings are changed
Top
See Also