Click or drag to resize

RhinoDocReplaceRhinoObject Event

Called if an object is about to be replaced. If both RhinoDoc.UndoActive() and RhinoDoc.RedoActive() return false, then immediately after the ReplaceObject event, there will be a DeleteObject event followed by an AddObject event. If either RhinoDoc.UndoActive() or RhinoDoc::RedoActive() return true, then immediately after the ReplaceObject event, there will be a DeleteObject event followed by an UndeleteObject event.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static event EventHandler<RhinoReplaceObjectEventArgs> ReplaceRhinoObject

Value

Type: SystemEventHandlerRhinoReplaceObjectEventArgs
See Also