Click or drag to resize

DisplayPipeline Events

The DisplayPipeline type exposes the following members.

Events
  NameDescription
Public eventStatic memberCalculateBoundingBox
Public eventStatic memberCalculateBoundingBoxZoomExtents
Calculate a bounding to include in the Zoom Extents command.
Public eventStatic memberDisplayModeChanged
Public eventStatic memberDrawForeground
Called after all non-highlighted objects have been drawn and PostDrawObjects has been called. Depth writing and testing are turned OFF. If you want to draw with depth writing/testing, see PostDrawObjects.
Public eventStatic memberDrawOverlay
If Rhino is in a feedback mode, the draw overlay call allows for temporary geometry to be drawn on top of everything in the scene. This is similar to the dynamic draw routine that occurs with custom get point.
Public eventStatic memberInitFrameBuffer
Public eventStatic memberObjectCulling
Public eventStatic memberPostDrawObject
Called right after an individual object has been drawn. NOTE: Do not use this event unless you absolutely need to. It is called for every object in the document and can slow display down if a large number of objects exist in the document
Public eventStatic memberPostDrawObjects
Called after all non-highlighted objects have been drawn. Depth writing and testing are still turned on. If you want to draw without depth writing/testing, see DrawForeground.
Public eventStatic memberPreDrawObject
Called right before an individual object is being drawn. NOTE: Do not use this event unless you absolutely need to. It is called for every object in the document and can slow display down if a large number of objects exist in the document
Public eventStatic memberPreDrawObjects
Called before objects are been drawn. Depth writing and testing are on.
Public eventStatic memberPreDrawTransparentObjects
Called before transparent objects have been drawn. Depth writing and testing are on.
Public eventStatic memberViewportProjectionChanged
Called when the projection changes for a viewport being drawn.
Top
See Also