Rhino C++ API  8.11
Public Member Functions | Friends | List of all members
RhRdk::Realtime2::ChangeQueue::GroundPlane Class Referencefinal

#include <RhRdk_RCE_Queue2.h>

Public Member Functions

 GroundPlane (const GroundPlane &)=delete
 
 GroundPlane (ON__UINT32 materialId, const ON_2dVector &vTextureScale, const ON_2dVector &vTextureOffset, double alt, double rot, bool on, bool showUnder, bool bShadowOnly)
 
 ~GroundPlane ()
 
double Altitude (void) const
 
ON__UINT32 CRC (void) const
 
bool Enabled (void) const
 
ON__UINT32 MaterialId (void) const
 
const GroundPlaneoperator= (const GroundPlane &)=delete
 
bool ShadowOnly (void) const
 
bool ShowUnderside (void) const
 
const ON_2dVectorTextureOffset (void) const
 
double TextureRotation (void) const
 
const ON_2dVectorTextureScale (void) const
 

Friends

class Impl
 

Constructor & Destructor Documentation

◆ GroundPlane() [1/2]

RhRdk::Realtime2::ChangeQueue::GroundPlane::GroundPlane ( ON__UINT32  materialId,
const ON_2dVector vTextureScale,
const ON_2dVector vTextureOffset,
double  alt,
double  rot,
bool  on,
bool  showUnder,
bool  bShadowOnly 
)

◆ ~GroundPlane()

RhRdk::Realtime2::ChangeQueue::GroundPlane::~GroundPlane ( )

◆ GroundPlane() [2/2]

RhRdk::Realtime2::ChangeQueue::GroundPlane::GroundPlane ( const GroundPlane )
delete

Member Function Documentation

◆ Altitude()

double RhRdk::Realtime2::ChangeQueue::GroundPlane::Altitude ( void  ) const

Altitude of the ground plane in the world

◆ CRC()

ON__UINT32 RhRdk::Realtime2::ChangeQueue::GroundPlane::CRC ( void  ) const

CRC of the groundplane for computed over all visible style affecting parameters.

◆ Enabled()

bool RhRdk::Realtime2::ChangeQueue::GroundPlane::Enabled ( void  ) const

true if the groundplane is enabled.

◆ MaterialId()

ON__UINT32 RhRdk::Realtime2::ChangeQueue::GroundPlane::MaterialId ( void  ) const

Material hash id used for this ground plane.

◆ operator=()

const GroundPlane& RhRdk::Realtime2::ChangeQueue::GroundPlane::operator= ( const GroundPlane )
delete

◆ ShadowOnly()

bool RhRdk::Realtime2::ChangeQueue::GroundPlane::ShadowOnly ( void  ) const

true if groundplane is shadows only.

◆ ShowUnderside()

bool RhRdk::Realtime2::ChangeQueue::GroundPlane::ShowUnderside ( void  ) const

true if should show through the underside.

◆ TextureOffset()

const ON_2dVector& RhRdk::Realtime2::ChangeQueue::GroundPlane::TextureOffset ( void  ) const

texture offset.

◆ TextureRotation()

double RhRdk::Realtime2::ChangeQueue::GroundPlane::TextureRotation ( void  ) const

texture rotation.

◆ TextureScale()

const ON_2dVector& RhRdk::Realtime2::ChangeQueue::GroundPlane::TextureScale ( void  ) const

texture scale.

Friends And Related Function Documentation

◆ Impl

friend class Impl
friend