Rhino C++ API  8.10
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDFaceRegion Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDFaceRegion ()=default
 
 ON_SubDFaceRegion (const ON_SubDFaceRegion &)=default
 
 ~ON_SubDFaceRegion ()=default
 
unsigned int CornerIndexFromVertexId (unsigned int vertex_id) const
 
bool IsValid (bool bSilentError) const
 
const ON_SubDFaceLevel0Face () const
 
ON_SubDFaceRegionoperator= (const ON_SubDFaceRegion &)=default
 
void Push (unsigned int quadrant_index)
 
const ON_wString ToString () const
 
wchar_t * ToString (wchar_t *s, size_t s_capacity) const
 

Public Attributes

ON_SubDComponentRegion m_edge_region [4]
 
ON_SubDComponentRegion m_face_region
 Identifies a region of an ON_SubDFace. More...
 
unsigned int m_level0_edge_count = 0
 
ON_SubDSectorId m_sector_id [4]
 
unsigned int m_vertex_id [4] = {}
 

Static Public Attributes

static const ON_SubDFaceRegion Empty