Rhino C++ API  8.10
Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ON_SubDExpandEdgesParameters Class Reference

#include <opennurbs_subd.h>

Public Types

enum  Style : unsigned char {
  Style::Unset = 0, Style::Single = 1, Style::Double = 2, Style::HalfLeft = 3,
  Style::HalfRight = 4
}
 ON_SubDExpandEdgesParameters::Style specifies options for how faces are inserted along input edges. More...
 

Public Member Functions

 ON_SubDExpandEdgesParameters ()=default
 
 ON_SubDExpandEdgesParameters (const ON_SubDExpandEdgesParameters &)=default
 
 ~ON_SubDExpandEdgesParameters ()=default
 
void ClearVariableOffset ()
 
double ConstantOffset () const
 Normalized constant offset parameter for inserting edges parallel to an input edge. Smaller values create narrower offsets. More...
 
const ON_Color FaceColor () const
 
Returns
Per face color for new faces.
More...
 
const ON_ComponentStatus FaceStatus () const
 
Returns
Status for new faces.
More...
 
ON_SubDExpandEdgesParameters::Style FaceStyle () const
 
const ON_SHA1_Hash Hash () const
 This SHA1 hash can be used to determine if sets of parameters are the same. More...
 
bool IsHalfFaceStyle () const
 
Returns
True if the FaceStyle() is HalfLeft of HalfRight.
More...
 
bool IsVariableOffset () const
 
ON_SubDExpandEdgesParametersoperator= (const ON_SubDExpandEdgesParameters &)=default
 
void SetConstantOffset (double offset)
 Set the constant offset value. Values within OffsetTolerance of a predefined offset value are set to the predefined offset value. More...
 
void SetFaceColor (ON_Color face_color)
 Set the perf face color for new faces. More...
 
void SetFaceStatus (ON_ComponentStatus face_status)
 Set the Mark(), MarkBits(), Selected(), and Highlighted() status for new faces. More...
 
void SetFaceStyle (ON_SubDExpandEdgesParameters::Style face_style)
 Set the style for new faces. More...
 
void SetVariableOffset (ON_Interval variable_offsets)
 
const ON_Interval VariableOffset () const
 

Static Public Member Functions

static double CleanupOffset (double x)
 
static bool IsValidConstantOffset (double constant_offset_candidate)
 
static bool IsValidForHalfOffset (const ON_SimpleArray< ON_SubDEdgePtr > &edges)
 Determine if the set of ON_SubDEdgePtrs can be sorted into a single edge chain that supports half side offsets. More...
 
static bool IsValidForVariableOffset (const ON_SimpleArray< ON_SubDEdgePtr > &edges)
 Determine if the set of ON_SubDEdgePtrs can be sorted into a single open edge chain supports variable offsets. More...
 
static bool IsValidVariableOffset (ON_Interval variable_offset_candidate)
 

Static Public Attributes

static const ON_SubDExpandEdgesParameters Default
 
static const double LargeOffset
 Large offset value (0.5) More...
 
static const double MaximumOffset
 Maximum permitted offset value (0.95) More...
 
static const double MediumOffset
 Medium offset value (0.25) More...
 
static const double MinimumOffset
 Minimum permitted offset value (0.05) More...
 
static const double OffsetTolerance
 OffsetTolerance = 0.001. More...
 
static const double SmallOffset
 Small offset value (0.125) More...
 

Detailed Description

ON_SubD