Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ON_SubD_ComponentIdTypeAndTag Class Reference

Simple arrays of ON_SubD_ComponentIdTypeAndTag elements are used to save original tag values so the can be retrieved after complex editing operations. More...

#include <opennurbs_subd.h>

Public Member Functions

ON_SubDComponentPtr::Type ComponentType () const
 
unsigned EdgeId () const
 
const ON_SubDEdgeSharpness EdgeSharpness (bool bUseCreaseSharpness) const
 
ON_SubDEdgeTag EdgeTag () const
 
unsigned FaceId () const
 
unsigned char FaceTag () const
 
void SetVertexSharpness (double s)
 
const ON_wString ToString () const
 
unsigned VertexId () const
 
const double VertexSharpness () const
 
ON_SubDVertexTag VertexTag () const
 

Static Public Member Functions

static int CompareTypeAndId (const ON_SubD_ComponentIdTypeAndTag *lhs, const ON_SubD_ComponentIdTypeAndTag *rhs)
 
static int CompareTypeAndIdAndTag (const ON_SubD_ComponentIdTypeAndTag *lhs, const ON_SubD_ComponentIdTypeAndTag *rhs)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromEdge (const class ON_SubDEdge *e)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromEdge (const class ON_SubDEdgePtr eptr)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromEdgeId (unsigned edge_id, ON_SubDEdgeTag etag)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromEdgeId (unsigned edge_id, ON_SubDEdgeTag etag, ON_SubDEdgeSharpness sharpness)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromFace (const class ON_SubDFace *f, unsigned char ftag)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromFaceId (unsigned face_id, unsigned char ftag)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromVertex (const class ON_SubDVertex *v)
 
static const ON_SubD_ComponentIdTypeAndTag CreateFromVertexId (unsigned vertex_id, ON_SubDVertexTag vtag)
 
static const ON_SubD_ComponentIdTypeAndTag FindFromTypeAndId (ON_SubDComponentPtr::Type type, unsigned id, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static ON_SubDEdgeTag OriginalEdgeTag (const class ON_SubDEdge *e, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static ON_SubDEdgeTag OriginalEdgeTag (unsigned edge_id, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static unsigned char OriginalFaceTag (const class ON_SubDFace *f, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static unsigned char OriginalFaceTag (unsigned face_id, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static ON_SubDVertexTag OriginalVertexTag (const class ON_SubDVertex *v, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 
static ON_SubDVertexTag OriginalVertexTag (unsigned vertex_id, const ON_SimpleArray< ON_SubD_ComponentIdTypeAndTag > &sorted_tags)
 

Static Public Attributes

static const ON_SubD_ComponentIdTypeAndTag Unset
 

Detailed Description

Simple arrays of ON_SubD_ComponentIdTypeAndTag elements are used to save original tag values so the can be retrieved after complex editing operations.