ModelInstanceDefinition Class |
Namespace: Grasshopper.Rhinoceros.Model
The ModelInstanceDefinition type exposes the following members.
Name | Description | |
---|---|---|
![]() | ModelInstanceDefinition | Initializes a new instance of the ModelInstanceDefinition class |
![]() | ModelInstanceDefinition(ModelInstanceDefinitionAttributes) | Initializes a new instance of the ModelInstanceDefinition class |
![]() | ModelInstanceDefinition(Guid) | Initializes a new instance of the ModelInstanceDefinition class |
![]() | ModelInstanceDefinition(InstanceDefinition) | Initializes a new instance of the ModelInstanceDefinition class |
Name | Description | |
---|---|---|
![]() | FilePath | |
![]() | IsValid | (Overrides ModelContentIsValid.) |
![]() | Objects | |
![]() ![]() | Unset | |
![]() | UpdateType | |
![]() | Url | |
![]() | UrlDescription | |
Name | Description | |
---|---|---|
![]() | BakeGeometry | |
![]() ![]() | Cast | |
![]() | CastToT(T) | (Overrides ModelContentCastToT(T).) |
![]() | GetBoundingBox | |
![]() | ToAttributes | |
Name | Description | |
---|---|---|
![]() ![]() | (ModelInstanceDefinitionAttributes to ModelInstanceDefinition) | |
![]() ![]() | (InstanceDefinition to ModelInstanceDefinition) | |
![]() ![]() | (String to ModelInstanceDefinition) |