ModelFont Class |
Namespace: Grasshopper.Rhinoceros
The ModelFont type exposes the following members.
Name | Description | |
---|---|---|
![]() | ModelFont | Initializes a new instance of the ModelFont class |
![]() | ModelFont(Font) | Initializes a new instance of the ModelFont class |
![]() | ModelFont(String) | Initializes a new instance of the ModelFont class |
Name | Description | |
---|---|---|
![]() | FamilyName | |
![]() ![]() | InstalledFamilies | |
![]() ![]() | InstalledFonts | |
![]() | IsInstalled | |
![]() | IsValid | (Overrides GH_GooTIsValid.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
Name | Description | |
---|---|---|
![]() | CastFrom | (Overrides GH_GooTCastFrom(Object).) |
![]() | Duplicate | (Overrides GH_GooTDuplicate.) |
![]() | Equals(ModelFont) | |
![]() | Equals(Object) | (Overrides ObjectEquals(Object).) |
![]() | GetHashCode | (Overrides ObjectGetHashCode.) |
![]() ![]() | IsFamilyNameInstalled | |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ToString | (Overrides GH_GooTToString.) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |
Name | Description | |
---|---|---|
![]() ![]() | (Font to ModelFont) | |
![]() ![]() | (String to ModelFont) |