AnnotationTextSettings Class |
Namespace: Grasshopper.Rhinoceros.Annotations
The AnnotationTextSettings type exposes the following members.
Name | Description | |
---|---|---|
![]() | AnnotationTextSettings | Initializes a new instance of the AnnotationTextSettings class |
![]() | AnnotationTextSettings(AnnotationTextSettingsAttributes) | Initializes a new instance of the AnnotationTextSettings class |
![]() | AnnotationTextSettings(DimensionStyle) | Initializes a new instance of the AnnotationTextSettings class |
Name | Description | |
---|---|---|
![]() | DrawForward | |
![]() | DrawTextMask | |
![]() | FitText | |
![]() | Font | |
![]() | MaskColor | |
![]() | MaskColorSource | |
![]() | MaskFrame | |
![]() | MaskOffset | |
![]() | TextGap | |
![]() | TextHeight | |
![]() | TextHorizontalAlignment | |
![]() | TextOrientation | |
![]() | TextVerticalAlignment |
Name | Description | |
---|---|---|
![]() | GetDimensionStyle | |
Name | Description | |
---|---|---|
![]() ![]() | (AnnotationTextSettings to DimensionStyle) | |
![]() ![]() | (AnnotationTextSettingsAttributes to AnnotationTextSettings) |