GH_Tooltip Class |
Namespace: Grasshopper.GUI
The GH_Tooltip type exposes the following members.
Name | Description | |
---|---|---|
Tag |
Gets or sets the tag object for the tooltip
| |
TooltipForm |
Gets the internal instance of GH_TooltipForm.
|
Name | Description | |
---|---|---|
Adjust |
Repositions the tooltip to match with new cursor positions.
| |
AssignTooltipFields |
Set all fields of the Tooltip. You'll still need to call Show() to display the tooltip.
| |
Clear |
Hides the tooltip and clears all references and caches.
| |
IsOwner |
Returns true if the test control matches the internal Owner control.
Use this method to make sure you actually own this tooltip prior to clearing it.
| |
IsTag |
Returns True if the test object matches the internal Tag object
| |
Layout |
Layout the tooltip fields. Layout happens automatically if you use the AssigTooltipField method,
if however you poke values directly in the tooltip form you must place a call to Layout() before
showing the tooltip.
| |
Show |
Display the tooltip on screen.
| |
TooltipDetailedInformation |