GH_DragInfo Class |
Namespace: Grasshopper.GUI
The GH_DragInfo type exposes the following members.
Name | Description | |
---|---|---|
GH_DragInfo |
Create a new DragInfo instance.
|
Name | Description | |
---|---|---|
Box_Drag |
Gets the dimensions of the box as a result of the dragging op.
| |
Box_Start |
Gets the dimensions of the drag box prior to dragging.
| |
Constraint |
Gets or sets the directional constraint for the drag operation.
| |
Point_Drag |
Gets the cursor location at the current moment.
| |
Point_Start |
Gets the cursor location at the start of the drag.
| |
Region |
Gets or sets the drag limits. If the region is Rectangle.Empty then the region is ignored.
For valid results the Region should be larger than the dimensions of the drag box.
|
Name | Description | |
---|---|---|
Drag |
Call this method to adjust the drag data. Results will be automatically constrained and limited.
|