GH_AnimatorT Class |
Namespace: Grasshopper.GUI
The GH_AnimatorT type exposes the following members.
Name | Description | |
---|---|---|
GH_AnimatorT(T, T, TimeSpan, GH_AnimatorTInterpolate) |
Create a new instance of the generic animator.
| |
GH_AnimatorT(T, T, DateTime, DateTime, GH_AnimatorTInterpolate) |
Create a new instance of the generic animator.
|
Name | Description | |
---|---|---|
Interpolation |
Gets or sets the interpolation mode. Changing the mode during an animation will result in discontinuous motion.
| |
Phase |
Gets the current animation phase.
| |
ValueA |
Gets or sets the start value of the animation.
This value is set from within the constructor though you can change it at any time.
| |
ValueB |
Gets or sets the end value of the animation.
This value is set from within the constructor though you can change it at any time.
|
Name | Description | |
---|---|---|
AdjustAnimation(T) |
Adjust the animation.
| |
AdjustAnimation(T, Int32) |
Adjust the animation.
| |
AdjustAnimation(T, DateTime, DateTime) |
Adjust the animation.
| |
CurrentValue |
Gets the current animated value.
|