GH_ScrollBarVerticalBase Class |
Namespace: Grasshopper.GUI.Base
The GH_ScrollBarVerticalBase type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_ScrollBarVerticalBase | Initializes a new instance of the GH_ScrollBarVerticalBase class |
Name | Description | |
---|---|---|
![]() | Content |
Gets or sets the height of the content
|
![]() | ContentOffset |
Gets the vertical offset (in pixels) of the scrolled content.
|
![]() | Display |
Gets or sets the height of the display area.
|
![]() | Minimum |
Gets or sets the minimum height of the scrollbar.
|
![]() | Offset |
Gets the offset of the scroller.
|
![]() | OffsetNormalised |
Gets or sets the normalised offset of the scroller.
|
Name | Description | |
---|---|---|
![]() | BeginDrag |
Start a new drag operation.
|
![]() | ContinueDrag |
Continue a drag operation.
|
![]() | ScrollBar(Rectangle) |
Compute the size and position of the scroll bar in the scroll rail.
|
![]() | ScrollBar(RectangleF) |
Compute the size and position of the scroll bar in the scroll rail.
|