ID Structure |
Namespace: GH_IO.Serialization
The ID type exposes the following members.
Name | Description | |
---|---|---|
![]() | ID(String) |
Constuctor for IDs.
|
![]() | ID(String, Int32) |
Constructor for IDs.
|
Name | Description | |
---|---|---|
![]() | Hash |
Gets the hash code.
|
![]() | HasIndex |
Gets whether the index has been set.
|
![]() | HasName |
Gets whether the name has been set.
Every valid ID must have a name.
|
![]() | Index |
Gets the index of this ID, if there is no valid index then -1 is returned.
|
![]() | Name |
Gets the name of this ID.
|
Name | Description | |
---|---|---|
![]() | CompareTo |
Compares this ID to another ID.
|
![]() | Equals |
Determines if two IDs are equal.
|
![]() | GetHashCode |
Gets the hash code.
(Overrides ValueTypeGetHashCode.) |
![]() | ToString |
Gets a string representation for this ID.
(Overrides ValueTypeToString.) |