IGH_ActiveObject Properties |
The IGH_ActiveObject type exposes the following members.
Name | Description | |
---|---|---|
![]() | Attributes |
Gets or sets the attributes that are associated with this object.
Only set custom attributes if you know what you are doing.
(Inherited from IGH_DocumentObject.) |
![]() | ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
ID that is used to identify objects of the same type.
(Inherited from IGH_DocumentObject.) |
![]() | Exposure |
Gets the exposure of this object in the Graphical User Interface.
(Inherited from IGH_DocumentObject.) |
![]() | Icon_24x24 |
The icon associated with this object.
(Inherited from IGH_DocumentObject.) |
![]() | Icon_24x24_Locked |
The greyscale icon of this object.
(Inherited from IGH_DocumentObject.) |
![]() | IconDisplayMode |
Gets the current display mode of the object.
(Inherited from IGH_DocumentObject.) |
![]() | IsDataProvider |
Gets whether or not this object is capable of emitting data.
|
![]() | Locked |
Gets or sets the locked flag of this object. Locked objects are ignored during solutions.
|
![]() | MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
The default is TRUE.
|
![]() | Obsolete |
Gets whether this object is Obsolete.
(Inherited from IGH_DocumentObject.) |
![]() | Phase |
Gets the solution phase in which this object is currently stuck.
|
![]() | ProcessorTime |
Gets the most recent measured processor time.
|
![]() | RuntimeMessageLevel |
Gets the worst-case level of all messages. I.e. if only warnings have been recorded,
the level will be ::warning. If even a single error exists, the level will be ::error.
|