GH_ComponentAttributes Properties |
The GH_ComponentAttributes type exposes the following members.
Name | Description | |
---|---|---|
Bounds |
Gets the rectangle that contains the active content of the attributes.
Typically the Contents determine the active area for menus, tooltips etc.
ContentBox |
Gets the bounds of the component area of the attributes.
HasInputGrip | (Overrides GH_AttributesTHasInputGrip.) | |
OutputGrip |
Gets the output grip location for these attributes.
Owner |
Gets the type-safe owner object of these attributes. This property is identical to
Parent |
Gets or sets the parent attributes.