GH_CanvasDropTargetValidator Properties |
The GH_CanvasDropTargetValidator type exposes the following members.
Name | Description | |
---|---|---|
Canvas |
Gets the canvas this validator is associated with.
(Inherited from GH_CanvasValidator.) | |
Document |
Gets the document (if it exists) that is currently loaded in the canvas.
(Inherited from GH_CanvasValidator.) | |
DropDelegate |
Gets or sets the delegate to be invoked when a component is dropped inside the dropregion.
| |
DropID |
Gets or sets the ID for the allowed component.
| |
DropRegion |
Gets or sets the dropregion for this validator.
Regions are cloned so you can dispose of the original immedately after assignment.
| |
DropText |
Gets or sets the text to display.
|